RAYMARINE - DSM 300 problems
Results 1 to 6 of 6

Thread: RAYMARINE - DSM 300 problems

  1. #1
    Senior Member
    Join Date
    Sep 2004
    Location
    Beach Haven, NJ (LBI)
    Posts
    1,741

    Default RAYMARINE - DSM 300 problems

    I've been very unhappy with my Raymarine C-120 since the day I had it installed on my center console. I like the actual unit and how easy it is to use, but I've had constant problems with it.

    While the sounder worked for a few weeks with little problem, things have gone down hill ever since. My radar sometimes doesn't even work. Lots of times it cuts out at the most important times leaving me in uncomfortable/dangerous positions.

    The "DSM connection lost" alarm constantly goes off and my sounder does not work due to "no data source." I've heard all of the horror stories, done my research, played with the unit and owner's manual and have had no luck.

    I can't afford to send the DSM back to the factory in the middle of the summer in fear of not getting it back for weeks. Atleast right now, sometimes my radar works.

    I installed the latest and greatest software update and nothing has improved with my problems.

    I used to lose my sounder pretty much only when starting my engines (understandable due to voltage issues) but now this no data source has got me really confused. The "DSM connection lost" alarm is quite irritating too. The status light on my DSM is orange (blinking) and sometimes straight green (inconsistantly).

    I'm open to all ideas...thanks for any help in advance.
    Brian Cartlidge
    Pez Machine Sportfishing
    Barnegat Light, NJ
    56' Custom Carolina

  2. Remove Advertisements
    TheBassBarn.com
    Advertisements
     

  3. #2
    Senior Member
    Join Date
    May 2009
    Posts
    2,747

    Default

    Quote Originally Posted by B Cartlidge View Post
    I've been very unhappy with my Raymarine C-120 since the day I had it installed on my center console. I like the actual unit and how easy it is to use, but I've had constant problems with it.

    While the sounder worked for a few weeks with little problem, things have gone down hill ever since. My radar sometimes doesn't even work. Lots of times it cuts out at the most important times leaving me in uncomfortable/dangerous positions.

    The "DSM connection lost" alarm constantly goes off and my sounder does not work due to "no data source." I've heard all of the horror stories, done my research, played with the unit and owner's manual and have had no luck.

    I can't afford to send the DSM back to the factory in the middle of the summer in fear of not getting it back for weeks. Atleast right now, sometimes my radar works.

    I installed the latest and greatest software update and nothing has improved with my problems.

    I used to lose my sounder pretty much only when starting my engines (understandable due to voltage issues) but now this no data source has got me really confused. The "DSM connection lost" alarm is quite irritating too. The status light on my DSM is orange (blinking) and sometimes straight green (inconsistantly).

    I'm open to all ideas...thanks for any help in advance.

    First and foremost, get a fully charged battery and run everthing directly to it. Most of the problems I have seen have been power related.

  4. #3
    Senior Member
    Join Date
    Aug 2004
    Location
    Mystic Islands, NJ
    Posts
    2,483

    Default

    Brian,

    It has been a while since I sold my boat that had the C120 in it, but when I first got it I had similar problems. The first thing I had to do was run a new dedicated power supply direct from one of the batteries to the units. I also installed a switch in the power line to the raystart gps sensor as it would burn out if kept powered all the time (previous owner had problems with unit). My neighbor had a problem with his C80 sounder part and he found that one of the small fuses in the line from the transducer had blown. I did not know that there were fuses there, but evidently there are.

    I had problems with my screen going black and I sent it back to raymarine in july and had it back in 2 weeks...
    Chris Miller
    1990 Grady 23 Gulfstream "CTALES V"
    1974 Mako 17 "Tiderunner"
    Mystic Islands, NJ (since 1970)

  5. #4
    Senior Member
    Join Date
    Sep 2004
    Location
    Beach Haven, NJ (LBI)
    Posts
    1,741

    Default

    Thanks for the responses and e-mails. I appreciate any and all feedback.
    Brian Cartlidge
    Pez Machine Sportfishing
    Barnegat Light, NJ
    56' Custom Carolina

  6. #5
    Member
    Join Date
    Feb 2002
    Location
    Little Egg Inlet
    Posts
    84

    Default I feel your pain

    I've had similar issues with my dsm300. Mine is networked via sea talk to two e120's. My unit is on it's 5th season. The first 3 seasons the unit worked flawlessly. I've sent the unit back to Raymarine, updated the software, isolated the power source, got seasick with my head in the cabinet trying to troubleshoot while underway. I'm tracing every wire that runs to it now. The most frustrating thing is that I can't recreate the issue with any regularity so I don't want to spend a ton of cash paying a tech to chase a ghost problem. It seems to always fail when I'm halfway to the fishing grounds or entering BH inlet! I'll let you know what I find when I finally fix the problem.
    HM

  7. #6
    Senior Member
    Join Date
    Sep 2004
    Location
    Beach Haven, NJ (LBI)
    Posts
    1,741

    Default

    Thanks for the responses guys. I appreciate it.

    Steve Bent (Free Spirit Charters) is a class act and is extemely knowledgeable with Raymarine electronics, power issues, and boats in general. You can tell that he has been in the industry for awhile, and I know why he is still around and busy today even in these tough economic times. Due to his help, I've been able to determine that my problem is simply related to power, or lack thereof.

    I can't say enough good things about Steve and his willingness to help someone that he does not know or is not making any money off of.

    I'm going to get this issue solved with a battery charger or maybe an additional battery if need be.

    Thanks again to everyone and especially Steve for going way above and beyond the call of duty.
    Brian Cartlidge
    Pez Machine Sportfishing
    Barnegat Light, NJ
    56' Custom Carolina

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •